Back to overview
Resolved

Maintenance: 15-08-2026

Aug 17, 2026 at 5:00am UTC  –  Aug 17, 2026 at 8:00am UTC
Affected services
Fralen
Fralen Creator Dashboard
Fralen Chat
Fralen Forum
Fralen Games
Fralen Support
Age Verification Tool
Fralen Blog

Resolved
Aug 17, 2026 at 8:00am UTC

Maintenance ended

Created
Aug 17, 2026 at 5:00am UTC

Fralen will partially be unreachable. Certain services might not work properly during this time.